Not all tags visible in List View

In list view, only two tags show. I’m guessing there’s an invisible column without enough room to show all tags, even when there’s plenty of room on the screen. I have a number of tasks where I need 3 tags. I realize custom tags can be a sort of workaround, but there’s also a limit to how many of them will fit on the screen.

We are considering changing this soon, you would have more options on how you would like to see the list.