BUG: Automation Error with Zapier

We are using the new Zapier beta integration to add tasks from our google sheets. However, sometimes these tasks become corrupted in the UI. We think it may have something to do with the Smart Genie, as when we refresh many of them become assigned to the Smart Genie. Screenshot of what the automated task looks like. These tasks cannot be deleted, but just reappear upon completion or deletion.

This may point to an issue in the Zapier action. Can you please make a detailed video of the automation you have created (including each value in the “Create Task” action) and share it on support@smarttask.io

We would be able to understand much better through it.

Ah, we were able to find the solution - while “Assignee” is shown as optional, assigning the tasks to our Automation User immediately solved this problem.

We do have other issues with the Zapier integration (new Projects not populating in dropdowns even on refresh fields, lines that have been deleted don’t trigger (ie, lines 1-5 on the spreadsheet cannot be used as they were part of our testing), created tasks include unnecessary formatting that we cannot turn off), but this one had an easy fix and the others were able to be worked around.

Glad that you were able to solve the issue.

With regards to projects not being loaded. Please understand this is by design of Zapier, that is why Zapier provides you with a way to directly enter ProjectId.

Going ahead and marking this as resolved.